百度360必应搜狗淘宝本站头条
当前位置:网站首页 > IT知识 > 正文

精!锐捷路由器配置命令大全,有案例分析

liuian 2025-03-07 20:50 34 浏览

一、路由器基本配置命令

由远程终端登录路由器

Red-Giant>enable ——由用户模式进入特权模式
Password:****** ——输入密码
Red-Giant#configure ——由特权模式进入全局配置模式
Configuring from terminal, memory, or network [terminal]? t ——输入 t继续
Red-Giant(config)#hostname Router ——修改路由器名称

配置接口IP地址

Router(config)#interface fastethernet 0 ——进入以太网口 0接口模式
Router(config-if)#ip address 192.168.1.1 255.255.255.0 ——为其配置 IP地址
Router(config-if)#no shutdown ——启用配置
Router(config-if)#exit ——退至配置模式
Router(config)#interface fastethernet 1 ——进入以太网口 0接口模式
Router(config-if)#ip address 192.168.2.1 255.255.255.0 ——为其配置 IP地址
Router(config-if)#no shutdown ——启用配置
Router(config-if)#exit ——退至配置模式
Router(config)#interface serial 0 ——进入 Serial 0 接口模式
Router(config-if)#ip address 192.168.3.1 255.255.255.0 ——为其配置 IP地址
Router(config-if)#no shutdown ——启用配置
Router(config-if)#exit ——退至配置模式
Router(config)#interface serial 1 ——进入 Serial 1 接口模式
Router(config-if)#ip address 192.168.4.1 255.255.255.0 ——为其配置 IP地址
Router(config-if)#no shutdown ——启用配置
Router(config-if)#end ——退至特权模式
Router#write ——保存配置信息
Router(config)#interface loopback 0 ——新建 Loopback 0
Router(config-if)#ip add 10.10.1.1 255.255.255.0 ——为其配置 IP地址
Router(config-if)#int loopback 1 ——新建 Loopback 1
Router(config-if)#ip add 10.10.2.1 255.255.255.0 ——为其配置 IP地址
Router(config-if)#end——退至特权模式

查看路由器相关配置信息

Router#show ip interface brief ——查看配置状态
Router#show version ——显示路由器版本信息
Router#show ip interface fastethernet 0 ——查看以太网口 0接口配置状态
Router#show running-config——显示当前运行的配置参数
Router#show startup-config——显示 NVRAM中中配置参数的副本
Router#copy running-config startup-config ——将当前运行的配置参数复制到 NVRAM
Router#erase startup-config——清空 NVRAM中的配置参数
Router#reload——重新启动路由器

配置console 登陆密码

Router(config)#line console 0
Router(config-line)#login
Router(config-line)#password star

配置VTY登陆密码

Router(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password star

配置特权模式登录密码

Router(config)#enable password star——配置明文密码
Router(config)#enable secret star——配置的密码不能与 password密码相同

二、路由器密码丢失的处理方法

  1. 关闭路由器,重新登录超级终端,按默认方法设置;
  2. 启动路由器,不停地按 Ctrl+Pause Break,直至出现 Boot:提示符,输入 Setup-Reg;
Boot:Setup-Reg
  1. 出现如下提示信息,按“ Y”回车确认:
Do you wish to change the configuration?y/n[n]:
  1. 出现提示如下信息,按“ Y”回车确认:
Enable“bypass the system configure file”y/n[n]:
  1. 出现提示如下信息,按“ N”回车确认:
Enable“debug mode?”y/n[n]:
  1. 出现提示如下信息,按“ N”回车确认:
Enable“user break/abort enabled?”y/n[n]:
  1. 出现提示如下信息,按“ N”回车确认:
Change console speed?y/n[n]:
  1. 出现提示如下信息,按“ N”回车确认:
Do you wish to change the configuration?y/n[n]:
  1. 出现提示符“Boot:”,输入Reset;
Boot:reset
  1. 出现提示如下信息,按“ N”回车确认:
Would you like to enter the initial configuration dialog?[Yes]:

此时密码及路由器信息被清除,你就可以顺利进入路由器了······ 可以归纳为“Setup-Reg,两个Y五个N,Reset”。

三、静态路由配置

两台路由器,其中 :

Route A

  • S0:192.168.3.1 ,
  • F1:192.168.2.1 ,
  • Loopback 1:12.12.1.1 ,
  • Loopback 2:12.12.2.1

Route B

  • S0:192.168.3.2 ,
  • F0:192.168.5.1 ,
  • Loopback 3:10.10.1.1 ,
  • Loopback 4:10.10.2.1

具体配置如下:

登录路由器并配置 F0、F1、S0、S1的IP地址

Router>en
Password:
Router#con
Configuring from terminal, memory, or network [terminal]? t

Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int f1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#int s1
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#end

新增Loopback1、Loopback2并为其配置 IP地址

Router#con
Configuring from terminal, memory, or network [terminal]? t
Router(config)#int loopback 1
Router(config-if)#ip address 12.12.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int loopback 2
Router(config-if)#ip address 12.12.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

指向下一跳 路由器

Router(config)#ip route 10.10.1.0 255.255.255.0 192.168.3.2
Router#show ip interface brief
Router#interface serial 0

设置接口物理时钟频率

Router#show control serial 0 ——查看Serial 0 接口型号
Router#configure
Configuring from terminal, memory, or network [terminal]? t
Router(config)#int s0
Router(config-if)#clock rate 64000 ——设置接口物理时钟频率为 64Kbps(DCE)
Router(config-if)#no shutdown
Router(config)#end

为Serial 0 封装PPP协议

Router#configure
Configuring from terminal, memory, or network [terminal]? t
Router(config)#int s0
Router(config-if)#enca ppp ——为Serial 0 封装PPP协议
Router(config-if)#end

测试路由配置信息及互联互通

Router#show ip route
Router#show ip interface brief
Router#show running-config
Router#Ping 192.168.3.1
Router#Ping 192.168.3.2
Router#Ping 10.10.1.1

接下来,在另一台路由器上进行相应配置,并测试互连互通。实验完成!!!

四、RIP动态路由配置

配置步骤:

  1. 启用RIP进程;
  2. 配置Network命令;
  3. 配置均载负衡(代价相等);
  4. 配置RIP发布初始度量值。

(一)配置命令

User Access Verification
Password:
Router>en
Password:

Router#con
Configuring from terminal, memory, or network [terminal]? t
Router(config)#router rip ——开启路由功能
Router(config-router)#version 2 ——升级至版本 2
Router(config-router)#no auto-summary ——在主类边界关闭自动汇总
Router(config-router)#network 192.168.1.0 ——配置 network命令
Router(config-router)#maximum-paths 4 ——配置均衡负载,缺省值为 4
Router(config-router)#default-metric 1 ——配置 RIP发布初始度量值,建议设置为 1
Router#show ip protocols ——验证RIP的配置
Router#show ip route ——显示路由表的信息
Router#clear ip route ——清除 IP路由表的信息
Router#debug ip rip ——在控制台显示 RIP的工作状态
Router#no debug all ——清除控制台显示 RIP的工作状态

(二)实验模型

拓朴图如下,用 RIP配置Route-A和Route-B之间的路由。

配置F0、F1和S0端口IP地址

User Access Verification
Password:
Router>en
Password:
Router#con
Configuring from terminal, memory, or network [terminal]? t
Router(config)#int f0
Router(config-if)#ip add 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int f1
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s0
Router(config-if)#ip add 10.1.1.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

开启RIP路由功能, 配置Network命令

Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary
Router(config-router)#network 10.1.1.0
Router(config-router)#network 172.16.1.0
Router(config-router)#network 172.16.2.0
Router(config-router)#end

查看配置信息,并测试配置正确与否

Router#show ip route
Router#show ip protocols
Router#debug ip rip
Router#no debug all
Router#ping 192.168.1.1
Router#ping 172.16.1.1
Router#ping 172.16.2.1

接下来,在另一台路由器上进行相应配置,并测试互连互通。实验完成!!!

五、交换机、路由器配置步骤简要说明

(一)配置说明

  1. 首先连接好设备,确保连接正确;
  2. 用超级终端进入路由器,如果忘记了密码,请按密码破解方法清除设置,还原默认设置;
  3. 查看各接口配置信息, “Show ip interface brief ” ,看以前的配置有没有保存在机器里面,视情进行清除设置;
  4. 查看交换机、路由器的配置, “show running -config”;
  5. 按自己的需要给交换机和路由器命名,以便于区分, “hostname XXXXXX”;
  6. 按照配置需求对交换机、路由器的各接口进行配置,配置之前最好查看一下接口时钟类型:
show controllers serial 0
clock rate 64000
no shutdown

记住:对接口配置完退至上一级时一定要保存配置,即 “no shutdown”;

  1. 配置完毕后,退至特权模式下,检查配置的正确与否。

(二)故障排除

如果两台路由器或交换机之间不能互连互通,请按照下列步骤进行检查:

  1. 检查Serial 接口的时钟频率;
  2. 检查同一介质上两个接口的 IP地址是不是在同一网段;
  3. 配置完接口后有没有 “no shutdwon”;
  4. 接口的封装协议是否相同;
  5. 有没有把 IP地址配置错误。

(三)三层交换机的有关说明

  1. 管理二层交换机的 IP地址只有一个生效,且为最后一个 “no shutdown”;
  2. 创建一个 Vlan,至少一个,为了冗余备份。

六、OSPF动态路由配置实验

配置步骤:

  1. 确定Area 0;
  2. 激活进程号;
  3. 反向掩码;
  4. 主干链路区域为 0。
User Access Verification
Password:
router>en


Password:
router#con
Configuring from terminal, memory, or network [terminal]? t
router(config)#int f0
router(config-if)#ip add 192.168.8.1 255.255.255.0
router(config-if)#no shutdown
router(config-if)#exit
router(config)#int f1
router(config-if)#ip add 192.168.2.1 255.255.255.0
router(config-if)#no shutdown
router(config-if)#exit
router(config)#int s0
router(config-if)#ip add 192.168.1.2 255.255.255.0
router(config-if)#no shutdown
router(config-if)#exit
router(config)#int s1
router(config-if)#ip add 192.168.3.2 255.255.255.0
router(config-if)#no shutdown
router(config-if)#int loopback 4
router(config-if)#ip add 12.12.1.1 255.255.255.0
router(config-if)#no shutdown
router(config-if)#int loopback 5
router(config-if)#ip add 12.12.2.1 255.255.255.0
router(config-if)#no shutdown
router(config-if)#int loopback 6
router(config-if)#ip add 12.12.3.1 255.255.255.0
router(config-if)#no shutdown
router(config-if)#exit

配置OSPF路由协议

router(config)#router ospf 11 ——激活进程号
router(config-router)#network 192.168.1.0 0.0.0.255 area 0 ——申明自治区域 0
router(config-router)#network 12.12.1.0 0.0.0.255 area 1 ——申明自治区域 1
router(config-router)#network 12.12.2.0 0.0.0.255 area 1
router(config-router)#network 12.12.3.0 0.0.0.255 area 1
router(config-router)#end
router#show ip protocols
router#show ip interface brief
router#show ip ospf neighbor

七、访问控制列表

Router#con
Configuring from terminal, memory, or network [terminal]? t
让用户D不能远程登录 A Router(config)#access-list 103 deny tcp host 192.168.3.139 host 192.168.5.165eq 23
Router(config)#access-list 103 permit ip any any
Router(config)#int Serial 0
Router(config-if)#ip access-group 103 out
记用户A不能问网络,而用户 B能够访问网络 Router(config)#access-list 12 deny 192.168.5.0 0.0.0.255
Router(config)#access-list 12 permit 192.168.6.0 0.0.0.255
Router(config)#int serial 0
Router(config-if)#ip access-group 12 out

Router(config-if)#no shutdown
Router(config-if)#end
Router#show ip access-list
八、封装 PPP协议验证 User Access Verification
Password:
router>en
Password:
router
#con
Configuring from terminal, memory, or network [terminal]? t
Red-Giant(config)#hostname Router
Router(config)#enable password star
Router(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password star
Router(config-line)#end
Router#show ip in b
Router#con
Configuring from terminal, memory, or network [terminal]? t
Router(config)#int f0
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int f1
Router(config-if)#ip add 192.168.3.1 255.255.255.0
Router(config-if)#no shu
Router(config)#int s0
Router(config-if)#clock rate 64000
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shu
Router(config-if)#end
Router#con
Configuring from terminal, memory, or network [terminal]? t
Router(config)#router ospf 11
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 1
Router(config-router)#network 192.168.3.0 0.0.0.255 area 1
Router(config-router)#end
Router#show ip ospf neighbor
Router#show ip interface brief
Router#ping 192.168.1.2
Router#show ip protocols
Router#show ip inter s0
Router#ping 192.168.1.2
Router#con
Configuring from terminal, memory, or network [terminal]? t
Router(config)#int loopback 1
Router(config-if)#ip add 11.1.1.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#in loopback 2
Router(config-if)#ip add 11.1.2.1 255.255.255.0
Router(config-if)#end
Router#show ip interface brief
Router#con
Configuring from terminal, memory, or network [terminal]? t
将Serial 0 封装PPP Router(config)#int s0
Router(config-if)#enca ppp
Router(config-if)#exit
Router(config)#hostname A
A(config)#username A password star ——此处用户名和密码由服务器端定义,用于客户端验证
A(config)#int s0
封装类型为 PAP A(config-if)#ppp authentication pap
A(config-if)#ppp pap sent-username A password star ——发送服务端提供的用户名和密码
封装类型为 CHAP A(config-if)#ppp authentication chap
A(config-if)#ppp chap hostname A
A(config-if)#ppp chap password star
A(config-if)#end
A#show inter s0
A#show run

相关推荐

【常识】如何优化Windows 7

优化Windows7可以让这个经典系统运行更流畅,特别是在老旧硬件上。以下是经过整理的实用优化方案,分为基础优化和进阶优化两部分:一、基础优化(适合所有用户)1.关闭不必要的视觉效果右键计算机...

系统优化!Windows 11/10 必做的十个优化配置

以下是为Windows10/11用户整理的10个必做优化配置,涵盖性能提升、隐私保护和系统精简等方面,操作安全且无需第三方工具:1.禁用不必要的开机启动项操作路径:`Ctrl+S...

最好用音频剪辑的软件,使用方法?

QVE音频剪辑是一款简单实用的软件,功能丰富,可编辑全格式音频。支持音频转换、合并、淡入淡出、变速、音量调节等,无时长限制,用户可自由剪辑。剪辑后文件音质无损,支持多格式转换,便于存储与跨设备播放,满...

Vue2 开发总踩坑?这 8 个实战技巧让代码秒变丝滑

前端开发的小伙伴们,在和Vue2打交道的日子里,是不是总被各种奇奇怪怪的问题搞得头大?数据不响应、组件传值混乱、页面加载慢……别慌!今天带来8个超实用的Vue2实战技巧,每一个都能直击痛...

Motion for Vue:为Vue量身定制的强大动画库

在前端开发中,动画效果是提升用户体验的重要手段。Vue生态系统中虽然有许多动画库,但真正能做到高性能、易用且功能丰富的并不多。今天,我们要介绍的是MotionforVue(motion-v),...

CSS view():JavaScript 滚动动画的终结

前言CSSview()方法可能会标志着JavaScript在制作滚动动画方面的衰落。如何用5行CSS代码取代50多行繁琐的JavaScript,彻底改变网页动画每次和UI/U...

「大数据」 hive入门

前言最近会介入数据中台项目,所以会推出一系列的跟大数据相关的组件博客与文档。Hive这个大数据组件自从Hadoop诞生之日起,便作为Hadoop生态体系(HDFS、MR/YARN、HIVE、HBASE...

青铜时代的终结:对奖牌架构的反思

作者|AdamBellemare译者|王强策划|Tina要点运维和分析用例无法可靠地访问相关、完整和可信赖的数据。需要一种新的数据处理方法。虽然多跳架构已经存在了几十年,并且可以对...

解析IBM SQL-on-Hadoop的优化思路

对于BigSQL的优化,您需要注意以下六个方面:1.平衡的物理设计在进行集群的物理设计需要考虑数据节点的配置要一致,避免某个数据节点性能短板而影响整体性能。而对于管理节点,它虽然不保存业务数据,但作...

交易型数据湖 - Apache Iceberg、Apache Hudi和Delta Lake的比较

图片由作者提供简介构建数据湖最重要的决定之一是选择数据的存储格式,因为它可以大大影响系统的性能、可用性和兼容性。通过仔细考虑数据存储的格式,我们可以增强数据湖的功能和性能。有几种不同的选择,每一种都有...

深入解析全新 AWS S3 Tables:重塑数据湖仓架构

在AWSre:Invent2024大会中,AWS发布了AmazonS3Tables:一项专为可扩展存储和管理结构化数据而设计的解决方案,基于ApacheIceberg开放表格...

Apache DataFusion查询引擎简介

简介DataFusion是一个查询引擎,其本身不具备存储数据的能力。正因为不依赖底层存储的格式,使其成为了一个灵活可扩展的查询引擎。它原生支持了查询CSV,Parquet,Avro,Json等存储格式...

大数据Hadoop之——Flink Table API 和 SQL(单机Kafka)

一、TableAPI和FlinkSQL是什么TableAPI和SQL集成在同一套API中。这套API的核心概念是Table,用作查询的输入和输出,这套API都是批处理和...

比较前 3 名Schema管理工具

关注留言点赞,带你了解最流行的软件开发知识与最新科技行业趋势。在本文中,读者将了解三种顶级schema管理工具,如AWSGlue、ConfluentSchemaRegistry和Memph...

大数据技术之Flume

第1章概述1.1Flume定义Flume是Cloudera提供的一个高可用的,高可靠的,分布式的海量日志采集、聚合和传输的系统。Flume基于流式架构,灵活简单。1.2Flume的优点1.可以和...